Sumotunes Documentation


Getting Started

Sumotunes is a digital music studio where you can compose music, create songs, play with instruments or remix other users’ original songs. Your music can be imported in Sumovideo as background music for your video or you can easily export it to MP3 for your use.

Interface

  1. Navbar. It provides an easy access to create a new song, import/export features, playback options and to add any instrument in the project.
  2. Playback. Here you can play/stop the playback and set the loop mode of your song.
  3. Controls. Here you can add a new instrument by clicking the “+” button, adjust the song master volume and master tempo (BPM).
  4. Instrument Track. Here you’ll find all the controls of a single track: track name, mute / solo option, adjust track volume or delete it.
  5. Patterns. These are the parts of your song, you can see a visual preview of the notes contained in every single pattern.
  6. Pattern Library. A library of patterns ready to be used in your song.
  7. Editor. Where you can edit notes of a pattern and compose your own melody.
  8. Pads. Where you can play notes / drum pad of the current instrument and record while playing
  9. Undo / Redo. Here you can undo / redo your actions anytime you want.

Open / Save song

You can save your project by clicking File -> Save Song, after you choose the name of your song, it will be saved on your device as .sumo file. You can easily open a song by clicking on File - Open Song, choosing the .sumo file of the song you want to import.

Download song

You can download your song as MP3 by clicking File -> Download to MP3. As soon as the song will be ready to export, you’ll be able to download the file in .mp3 format. Note that you can’t import a MP3 file as Sumotunes project, you’ll need to save it as .sumo file.

Undo/Redo

You can undo any action by clicking the undo / redo buttons in the top right corner of the window or through the navbar menu Edit -> Undo / Redo.


Playback

Play/Stop

You can play / stop the song playback by clicking the yellow button in the bottom toolbar or through the navbar menu Playback -> Play / Stop

Loop Mode

You can set the song loop mode by clicking the button in the bottom toolbar or through the navbar menu Playback -> Loop Mode. There are 4 types of loop mode:

  • None (there will be no loop)
  • Single Part (the current part will be looped but only the selected instrument will play)
  • Parts (all the instrument will loop the current part)
  • Song (the song will be looped seamlessly)

Tempo

You can adjust the master tempo by clicking on the button in the bottom bar and change it by moving the slider. Minimum tempo is 20, maximum tempo 250.

Master Volume

You can adjust the master volume by clicking on the button in the bottom bar and change it by moving the slider. Note that if you lower the volume of a track or mute it, you won’t able to hear anything even if the master volume is set to maximum.


Tracks

Volume

You can adjust the volume of a track by using the yellow slider on the right of the instrument icon. Minimum value is 0 (no sound), maximum value is 100. Note that if you lower the master volume or keep it to 0 you won’t able to hear any sound.

Mute/Solo

You can mute or solo a track by clicking the buttons on the left of the instrument icon. If you mute the track you won’t hear any sound from it and if you solo the track you’ll only hear sounds from the current track and mute any other instruments in the song.

Delete track

You can delete the track by clicking the X button, you’ll be asked for confirmation but you can always undo the action further.

Patterns

Add pattern

You can add a new pattern by clicking the “Add Song Part” button at the end of the instrument track.

Edit pattern

You can edit a pattern by clicking on the icon in the bottom area of the one you selected, the piano roll editor will be opened and you can start inserting new notes.

Duplicate pattern

You can duplicate a pattern by clicking on the icon in the top left area of the one you selected.

Remove pattern

You can remove a pattern by clicking on the icon in the top left area of the one you selected.


Editor

Add / Delete note

You can add or delete a note in the piano roll by clicking on the grid. If you click on a empty space you will add a new note and if you click on a existing one you will delete it.

Cut/Copy/Paste note

You can copy or cut a pattern notes by clicking the buttons on the toolbar, then you can paste them in a new pattern by clicking the button next to it. To completely erase a pattern, just click on the X button.

Note Length

You can choose the note length by selecting the following options in the dropdown: 1/16, 1/8, 1/4, 1/2, 1/1.

Musical scale

You can choose the grid notes scale by selecting the options in the dropdown: All Keys will show all the notes, Pentatonic will show the notes in a pentatonic scale following the scale key.

Scale key

If you’re using a Pentatonic music scale, you can choose the scale key by selecting a note in the dropdown.


Pads

Pads basics

You can play your instrument by clicking on the pads. The same notes shown in Editor view will be displayed, so you might not find all the keys if you’ve chosen a Pentatonic scale.

Record performance while playing

You can record your performance while playing by selecting the checkbox, just play the song and tap the pads to record the notes in the current pattern.